advertisement
Forums

The Forum is sponsored by 
 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
Father at 10.5.8… Need to update...
Posted by: spacescape
Date: March 01, 2015 09:39AM
My father has an Intel iMac… Pretty sure it's a C2D… Pretty sure it's 22"… Just can't remember (sorry)… But, he's at 10.5.8 and needs to update the OS ASAP… A printer he deals with needs him to use a program that needs him to update. I'm trying to be cautious so he doesn't have issues with any of the programs he's using to avoid updating everything. I found him a copy of Snow Leopard (10.6)… But, can't remember… was 10.7 a "free" download? Would like to get him to 10.8 but I'm not sure if I still have the update or not…

Advice? Tips?
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: decay
Date: March 01, 2015 09:44AM
10.7 was $30 I think.
I know 10.8 is still available for $20



---
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: mattkime
Date: March 01, 2015 10:04AM
might as well jump all the way into the future.



Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: MEG
Date: March 01, 2015 10:06AM
10.7 was $30. Not sure about 10.8

If you ever purchased either update from the App Store, you can always download it again. Then I'd suggest using a flash drive (8GB or 16GB will do) to make a boot disk for the OS installer of choice.

You could just send flash drive to your dad and not worry about the rest...just saying...
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: jdc
Date: March 01, 2015 10:41AM
Not to get off topic -- but every printer should be able to take s PDF made from any app?



----


Edited 999 time(s). Last edit at 12:08PM by jdc.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: sekker
Date: March 01, 2015 11:09AM
Going beyond 10.6 means losing PPC apps (that use Rosetta under 10.5).

If if can go to 10.8, might as well go to 10.10. If you have a Mac, you can download and save the 10.10 installer. Should work fine on his machine IF the hardware is ready.

Moving up WILL require you to consider hardware - RAM and (likely) an external SSD would be a big improvement. If it's a C2D, I think you will be able to have 3GB RAM minimum (if not more).

The main advantage of 10.7 or above is that you will have Apple software support for security.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: The UnDoug
Date: March 01, 2015 11:46AM
Father 10.5.8 was a pretty good version of Father. I wouldn't update.


winking smiley



[www.zeemaps.com]
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: Black
Date: March 01, 2015 12:17PM
Quote
spacescape
My father has an Intel iMac… Pretty sure it's a C2D… Pretty sure it's 22"… Just can't remember (sorry)…

Advice? Tips?

Nobody here can give meaningful advice without knowing for sure that you have a C2D. There has never been a 22" iMac.




New forum user map 8/2015: [www.zeemaps.com]
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: The Grim Ninja
Date: March 01, 2015 01:01PM
Although it's going to sound rude, I agree with Black. The information given is completely useless.

Beyond the exact model he has, it would be nice to know what app are essential to his workflow and what versions they are.


If money isn't a huge issue, it might be worth considering replacing the whole kit. 10.5 is 8 years old after all, so his hardware is at least that old.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: spacescape
Date: March 01, 2015 01:02PM
Quote
The Grim Ninja
Although it's going to sound rude, I agree with Black. The information given is completely useless.

Beyond the exact model he has, it would be nice to know what app are essential to his workflow and what versions they are.


If money isn't a huge issue, it might be worth considering replacing the whole kit. 10.5 is 8 years old after all, so his hardware is at least that old.

True… I will find out more info and come back… But, will be getting him 10.7 for now…
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: Speedy
Date: March 01, 2015 01:07PM
Quote
spacescape
But, will be getting him 10.7 for now…

The worst of all choices.



Saint Cloud, Minnesota, where the weather is wonderful even when it isn't.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: jdc
Date: March 01, 2015 02:03PM
I still stand by my post. No printer should dictate what you have to run.

PDFs. period. I could fire up a OS 9.2 machine with PageMaker 5 and still make PDFs that any printer on the planet should be able to use just fine.

Sounds like A LOT of work for you and your dad -- money for an OS and then money for a new app?

Find a new printer?



----


Edited 999 time(s). Last edit at 12:08PM by jdc.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: Rick-o
Date: March 01, 2015 02:06PM
Quote
The UnDoug
Father 10.5.8 was a pretty good version of Father. I wouldn't update.


winking smiley

I read this topic earlier today. I said to myself, "Self, someone is going to make an updated Father comment."

I was right. big grin smiley



Mr. Lahey: A lot of people, don’t know how to drink. They drink against the grain of the liquor. And when you drink against the grain of the liquor? You lose.

Randy: What the @#$%& are you talking about?
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: Surfrider
Date: March 01, 2015 02:47PM
Some programs won't run well on 10.10, they run better on 10.8.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: sekker
Date: March 01, 2015 04:24PM
Quote
Surfrider
Some programs won't run well on 10.10, they run better on 10.8.

Fewer wifi issues too, I suppose.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: Rolando
Date: March 01, 2015 04:53PM
If it can run 10.9, go for it. If it can't then go with 10.6x.



San Antonio, TX (in the old city)


"All that is required for evil to prevail is for good men to do nothing." - Edmund Burke
“Neutrality helps the oppressor, never the victim. Silence encourages the tormentor, never the tormented." - Eli Weisel

"To announce that there must be no criticism of the President, or that we are to stand by the President, right or wrong, is not only unpatriotic and servile, but is morally treasonable to the American public." - Theodore Roosevelt (1918)

"I don’t want to see religious bigotry in any form. It would disturb me if there was a wedding between the religious fundamentalists and the political right. The hard right has no interest in religion except to manipulate it." - Billy Graham 1981

"Politics and governing demand compromise. But these Christians believe they are acting in the name of God, so they can't and won't compromise" - Barry Goldwater
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: hal
Date: March 01, 2015 05:03PM
I agree with jdc - find a new printer.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: Buzz
Date: March 01, 2015 10:40PM
Quote
Black
Quote
spacescape
My father has an Intel iMac… Pretty sure it's a C2D… Pretty sure it's 22"… Just can't remember (sorry)…

Advice? Tips?

Nobody here can give meaningful advice without knowing for sure that you have a C2D. There has never been a 22" iMac.

I was assuming it's a 21.5" rounded up to 22"... and there was one round of C2D's in that size, which do go to Yosemite, so software/OS shouldn't be an issue... OTOH, it's the earlier 20" C2D that was the last to run 10.5.x, so the info provided is inconclusive, but it, too, can go to Yosemite. Tough call to consider if a bunch of other apps are involved, so the print from pdf's and/or get a new/different printer *may* be the least invasive options, if those other apps (needing updates) are really a major headache. Avoiding Lion (10.7) is the best advice.
==
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: silvarios
Date: March 02, 2015 01:13AM
I agree. 10.7, while having some nice updates to 10.6, has been an absolute dog for me. Three Macs currently running Lion. An SSD is pretty much required for smooth performance.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: spacescape
Date: March 02, 2015 05:32AM
Thanks guys... The printer is not his printer but a printer of choice by his client which is the largest client he has. Everything is sent PDF however they have an uploading procedure that needs 10.7 to run that app. This isn't his choice. I told him it's time to buy a new mac yet he doesn't want too... He's 68 and doesn't like change... Still has my Dual 533 G4 running his "older apps"... Which he doesn't need often.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: silvarios
Date: March 02, 2015 10:47AM
Quote
spacescape
Thanks guys... The printer is not his printer but a printer of choice by his client which is the largest client he has. Everything is sent PDF however they have an uploading procedure that needs 10.7 to run that app. This isn't his choice. I told him it's time to buy a new mac yet he doesn't want too... He's 68 and doesn't like change... Still has my Dual 533 G4 running his "older apps"... Which he doesn't need often.

10.7 to upload PDFs? Is it some sort of custom Java applet on the site?



Edited 1 time(s). Last edit at 03/02/2015 11:47AM by silvarios.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: clay
Date: March 02, 2015 11:41AM
uh, 10.7 is $20 direct from Apple (can still buy it)

[store.apple.com]
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: silvarios
Date: March 02, 2015 11:48AM
Quote
clay
uh, 10.7 is $20 direct from Apple (can still buy it)

[store.apple.com]

If possible, avoid 10.7.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: jdc
Date: March 03, 2015 01:53AM
Quote
spacescape
Thanks guys... The printer is not his printer but a printer of choice by his client which is the largest client he has. Everything is sent PDF however they have an uploading procedure that needs 10.7 to run that app. This isn't his choice. I told him it's time to buy a new mac yet he doesn't want too... He's 68 and doesn't like change... Still has my Dual 533 G4 running his "older apps"... Which he doesn't need often.

Hmmmm -- Im gonna make another educated guess -- maybe its his browser thats the issue with the uploads?

Safari in 10.5.8 (and even 10.6.8), is outdated, tons of error messages with sites that use java. I upload pages to a printer with a custom web portal and I don't think I could use Safari when I was running 10.6.8 even just a year ago. But FF works fine, cause its the latest and greatest.

The latest Chrome or FF won't run in 10.5.8 -- however, they *will* run in 10.6.8. Maybe he can just jump to 10.6.8 and not 10.7?



----


Edited 999 time(s). Last edit at 12:08PM by jdc.
Options:  Reply • Quote
Re: Father at 10.5.8… Need to update...
Posted by: silvarios
Date: March 03, 2015 12:42PM
Quote
jdc
Quote
spacescape
Thanks guys... The printer is not his printer but a printer of choice by his client which is the largest client he has. Everything is sent PDF however they have an uploading procedure that needs 10.7 to run that app. This isn't his choice. I told him it's time to buy a new mac yet he doesn't want too... He's 68 and doesn't like change... Still has my Dual 533 G4 running his "older apps"... Which he doesn't need often.

Hmmmm -- Im gonna make another educated guess -- maybe its his browser thats the issue with the uploads?

Safari in 10.5.8 (and even 10.6.8), is outdated, tons of error messages with sites that use java. I upload pages to a printer with a custom web portal and I don't think I could use Safari when I was running 10.6.8 even just a year ago. But FF works fine, cause its the latest and greatest.

The latest Chrome or FF won't run in 10.5.8 -- however, they *will* run in 10.6.8. Maybe he can just jump to 10.6.8 and not 10.7?

Good point.
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 180
Record Number of Users: 186 on February 20, 2020
Record Number of Guests: 5122 on October 03, 2020