The Forum is sponsored by 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
Wi Fi Question
Posted by: mjgkramer
Date: November 25, 2016 03:57PM
Wife and I recently moved into a senior apartment facility which provides free password-protected Wi-Fi. Although both iMacs can access Internet they cannot see each other or my laser printer or inkjet. To do filesharing I have to use Drop box or iCloud or disconnect both iMacs from Internet and create a computer to computer network which isn't convenient and does not permit printer sharing. What do I have to do to have Wi-Fi access to Internet and have normal local area network functionality?
Options:  Reply • Quote
Re: Wi Fi Question
Posted by: nwyaker
Date: November 25, 2016 04:06PM

Edited 1 time(s). Last edit at 11/25/2016 04:08PM by nwyaker.
Options:  Reply • Quote
Re: Wi Fi Question
Posted by: gabester
Date: November 25, 2016 04:50PM
Sounds like your facility's Wi-Fi doesn't allow all the necessary communication ports to allow your Macs to share files or access networked printers. Step 1 would be to determine whether this is because they don't allow it at all, or they just don't allow the Apple-specific ports. In other words, enable the Macs' Windows-sharing aspects and see if you can connect for filesharing and printing over smb/cifs.
Options:  Reply • Quote
Re: Wi Fi Question
Posted by: GGD
Date: November 25, 2016 06:03PM
They might not want to enable other computer to see each other so that all the computers in the whole building aren't visible to each other.

Do they have Ethernet wiring to each apartment? In which case you might be able to setup your own WiFi router and LAN.

If not, if you have a Mac that has an Ethernet port, you could use it to do Internet sharing (in the Sharing system preference), and share the WiFi internet connection to it's Ethernet port, and then setup your own WiFi router (configured as just an access point, the Mac will really be the router) and LAN from there.

Edited 1 time(s). Last edit at 11/25/2016 06:03PM by GGD.
Options:  Reply • Quote
Re: Wi Fi Question
Posted by: Article Accelerator
Date: November 25, 2016 06:57PM
Just spitballing here, but you may be able use two Airport Express units. Set up one as client of the facility's WiFi and put it into "proxySTA" mode and connect it to the other via ethernet and put that one into "create a wireless network" (i.e. WiFi access point) mode.


GGD's second suggestion should work but that will require the "sharing" computer to be awake in order for the other computer to have access.
Options:  Reply • Quote
Re: Wi Fi Question
Posted by: Done
Date: November 25, 2016 11:04PM
Will back to my Mac work? May be a little slow.

Apple back to my Mac instructions

How to set up printer on Back to my mac
Options:  Reply • Quote
Re: Wi Fi Question
Posted by: Onamuji
Date: November 26, 2016 12:59AM
The routers aren't passing mDNS/Bonjour.

Try connecting via IP address.

With file sharing enabled on computer-A, note it's IP address and then in the Connect to Server window on Computer-B enter the IP address from Computer-A.

...Or if you just want to move a few files back an forth, use AirDrop.

...And for printing, you may need to assign a static IP to each printer, then make an IP print queue. (Assumes that the printers are networkable.) Use whatever network info they're pulling already via DHCP.

If this seems difficult, you may need to recruit a youngster to help with the setup.

Options:  Reply • Quote
Re: Wi Fi Question
Posted by: fauch
Date: November 26, 2016 11:59AM
They probably have AP isolation turned on which means that there can be no direct network communication between devices on the network.

What you can do is get your own router with repeater functionality on a different subnet and then everything on your private subnet will be able to see each other.
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 300
Record Number of Users: 52 on November 20, 2014
Record Number of Guests: 2330 on October 25, 2018