advertisement
Forums

The Forum is sponsored by 
 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
"Spotlight Web Content" eating the CPU
Posted by: Winston
Date: January 11, 2018 09:07PM
I don't use Spotlight much. I have Spotlight Suggestions turned off.

Just did a Spotlight search to try to fix a bad alias, and suddenly my Mac almost stopped. Activity Monitor showed "Spotlight Web Content" taking up to 80%+ of the CPU, even after I closed Spotlight. I also have Bing search turned off.

I did a force quit on Spotlight Web Content in Activity Monitor, and things returned to normal.

OS 10.11.6.

What would cause Spotlight Web Content to go bonkers?

Just after that Amazon Drive, which I'm not using, revved up for a minute or so. Running an Avast scan just in case.

Did another Spotlight search, and Spotlight Web Content came back. Not as bad as the first time, but still hit nearly 40% of CPU.


- W



------------------------
Be seeing you.



Edited 1 time(s). Last edit at 01/11/2018 09:15PM by Winston.
Options:  Reply • Quote
Re: "Spotlight Web Content" eating the CPU
Posted by: Onamuji
Date: January 11, 2018 09:45PM
All sorts of privacy implications with leaving that on.

Why not just refrain from overthinking and simply disable all that cr@p in the Spotlight pref's?



Options:  Reply • Quote
Re: "Spotlight Web Content" eating the CPU
Posted by: jdc
Date: January 11, 2018 09:57PM
Quote
Winston
Running an Avast scan just in case.

Just in case of what?

Spotlight prob just crashed. No biggie.

A restart would fix it.



----


Edited 999 time(s). Last edit at 12:08PM by jdc.
Options:  Reply • Quote
Re: "Spotlight Web Content" eating the CPU
Posted by: Winston
Date: January 11, 2018 10:02PM
Quote
Onamuji
All sorts of privacy implications with leaving that on.

Why not just refrain from overthinking and simply disable all that cr@p in the Spotlight pref's?


I have. There's only one button;
"Allow Spotlight Suggestions in Spotlight and Look Up" and it's not checked.

The only other item which looks web related is "Bing Web Searches" in the list of places to search, and that's not checked either. The only other things I can imagine could interact with the web are "Conversion" and "Definition".


ps: Tried toggling Spotlight Suggestions on and then off. Didn't seem to change anything.


- W



------------------------
Be seeing you.



Edited 2 time(s). Last edit at 01/11/2018 10:07PM by Winston.
Options:  Reply • Quote
Re: "Spotlight Web Content" eating the CPU
Posted by: Winston
Date: January 11, 2018 10:14PM
Quote
jdc
[A restart would fix it.

Good suggestion. I've gotten so used to OS X stability. Hardly ever have to restart due to an issue. (Although, even though it's pretty rare, it's more frequent with OS 10.11 than it was with OS 10.4 on my PowerBook. Feel like I never had to restart that.)



------------------------
Be seeing you.
Options:  Reply • Quote
Re: "Spotlight Web Content" eating the CPU
Posted by: jdc
Date: January 11, 2018 10:29PM
Quote
Winston
Quote
jdc
[A restart would fix it.

Good suggestion. I've gotten so used to OS X stability. Hardly ever have to restart due to an issue. (Although, even though it's pretty rare, it's more frequent with OS 10.11 than it was with OS 10.4 on my PowerBook. Feel like I never had to restart that.)

Its like our iphone/ipads -- never a restart, ever -- and if you asked a 1000 random people they would say the same.



----


Edited 999 time(s). Last edit at 12:08PM by jdc.
Options:  Reply • Quote
Re: "Spotlight Web Content" eating the CPU
Posted by: Onamuji
Date: January 12, 2018 05:37PM
Did you got to Safari > Preferences > Search and disable Spotlight suggestions from there?

(Don't recall if that option is available in 10.11, but worth checking.)

Could also try this in the Terminal to turn it off:
launchctl unload /System/Library/LaunchAgents/com.apple.metadata.SpotlightNetHelper.plist



Options:  Reply • Quote
Re: "Spotlight Web Content" eating the CPU
Posted by: Winston
Date: January 12, 2018 08:00PM
Quote
Onamuji
Did you got to Safari > Preferences > Search and disable Spotlight suggestions from there?

(Don't recall if that option is available in 10.11, but worth checking.)

There are preferences there, but they all relate to autofilling the Safari search bar. No mention of Spotlight.

Will take a look at the Terminal command if the problem persists. Thanks!


- W



------------------------
Be seeing you.
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 210
Record Number of Users: 52 on November 20, 2014
Record Number of Guests: 847 on February 04, 2015