advertisement
Forums

The Forum is sponsored by 
 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
OWC Mercury Pro Qx2 (2011) – gone belly up?
Posted by: StingMe
Date: August 29, 2019 06:23PM
Any Qx2 owners around?

Back in 2011 I picked up an OWC Mercury Elite-AL Pro Qx2 eSATA, FireWire 800+USB 2.0 and installed 4-2TB WD Black drives in it (RAID 5) and it worked well for a few years and then sat unused for a period of time.

When I reconnected it to my iMac and powered it on it went through the normal boot process and the fan kicked in but the volume wasn't mounted and the unit began a series of repeating double beeps. I removed all of the drives and powered it on again with the same result. I tried booting with a different (known good and empty) drive (RAID off) with the same result. I tried the single drive in each of the 4 bays, no change.

I haven't been able to find anything online regarding the beeping or any useful troubleshooting steps to take. Is this enclosure TOAST or what? It seems that the power supply and fan are ok (in that they both appear to be operating normally) so I guess that pretty much leaves the controller board.

Out of all the OWC enclosures I've purchased personally and professionally over the years this was the most expensive one and the only one that has gone belly up to date (virtually all of the others are still in use) - I'm bummed! Any suggestions for bringing this Qx2 back to life or do I just need to part it out and move on?

Thanks in advance! ~Jim
Options:  Reply • Quote
Re: OWC Mercury Pro Qx2 (2011) – gone belly up?
Posted by: hal
Date: August 29, 2019 06:27PM
I'd bet that the power supply is dead or nearly dead - call OWC - they sell replacements.

PS - check your other OWC enclosures, one might have the same power supply. Swap and test...



Edited 1 time(s). Last edit at 08/29/2019 06:28PM by hal.
Options:  Reply • Quote
Re: OWC Mercury Pro Qx2 (2011) – gone belly up?
Posted by: StingMe
Date: August 29, 2019 06:48PM
I have a plethora of power supplies but the QX2's is internal...

Options:  Reply • Quote
Re: OWC Mercury Pro Qx2 (2011) – gone belly up?
Posted by: rz
Date: August 30, 2019 03:16PM
call or chat with OWC. They should be able to diagnose it for you.

I have a QX2, but it's the USB 3 version. I use it to hold backup drives. It only gets turned on when I need to backup two of my internal drives. No problems so far.
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 256
Record Number of Users: 186 on February 20, 2020
Record Number of Guests: 2330 on October 25, 2018