advertisement
Forums

The Forum is sponsored by 
 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
Albook 1.5ghz: Pop noise and no power
Posted by: pRON aHOLIC
Date: June 05, 2006 02:19AM
Opened up my laptop sans AC adapter and got a big pop noise and the laptop powered off.

The battery shows 3 out of 5 dots on green so the battery has juice. I removed the battery and reinserted it. Still no go.

When I plug in the AC adapter the ring on the plug that usually shows orange or green is not on.

Any suggestions before I have to take this thing to a repair place?

BTW, this is my work's laptop and I just found out that we have no backups despite daily use as the editing and transmission tool for my job. This is going to get fun, I can tell already.



-------------------------------------------------------

Join team 38910 folding! [folding.stanford.edu] multi cpu-[calxalot.homeip.net]
Options:  Reply • Quote
Re: Albook 1.5ghz: Pop noise and no power
Posted by: Spiff
Date: June 05, 2006 07:32AM
Hmmm. It might be in need of a professional going over. It sounds like a power adapter something-or-other went kerplooey inside. Especially since the power cord does not glow green or orange - that's a bad sign. Good luck.
Options:  Reply • Quote
Re: Albook 1.5ghz: Pop noise and no power
Posted by: Baby Tats
Date: June 05, 2006 08:49AM
At least your HDD is probably OK. When a piece of electronic equipment makes a "pop noise", it generally isn't a very good sign. If you're lucky, it will be cheaper to replace it with a MacBook Pro than to repair it. Assuming of course that someone else is footing the bill.

BT
Options:  Reply • Quote
Re: Albook 1.5ghz: Pop noise and no power
Posted by: WillyB
Date: June 05, 2006 06:02PM
Maybe it's a lucky break?
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 114
Record Number of Users: 186 on February 20, 2020
Record Number of Guests: 5122 on October 03, 2020