advertisement
Forums

The Forum is sponsored by 
 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
setting preview not adobe reader in safari
Posted by: robfilms
Date: November 21, 2011 06:34AM
ever since i have switched back to safari from dog slow firefox8, i've had to re-learn how to set-up my browser preferences.

i like apple's preview rather than adobe's reader.

i have forgotten how to set it up in safari.

i didn't see an option under safari preferences.

thanks in advance to those who care to share.

be well

rob
Options:  Reply • Quote
Re: setting preview not adobe reader in safari
Posted by: WHiiP
Date: November 21, 2011 06:39AM
Use Get Info on one of your PDFs to change the default app for all PDFs.

Google is still your friend.



Bill
Flagler Beach, FL 32136

Carpe Vino!

Fermentation may have been a greater discovery than fire.
— David Rains Wallace
Options:  Reply • Quote
Re: setting preview not adobe reader in safari
Posted by: silvarios
Date: November 21, 2011 09:46AM
Quote
WHiiP
Use Get Info on one of your PDFs to change the default app for all PDFs.

Google is still your friend.

Don't think that works for PDFs loading directly in Safari.

Rob,
I think you might have to remove the Adobe plug-in to allow the native PDF plug-in to function. Assuming you don't occassionally need the Acrobat plug-in of course.
Options:  Reply • Quote
Re: setting preview not adobe reader in safari
Posted by: silvarios
Date: November 21, 2011 09:51AM
I should add, depending on the version of Acrobat, you might be able to disable the feature from within Acrobat preferences. However, if you really don't need the functionality just take my first suggestion and remove the plug-in altogether. Check /Library/Internet Plugins.
Options:  Reply • Quote
Re: setting preview not adobe reader in safari
Posted by: MEG
Date: November 21, 2011 10:01AM
If you want to have Preview open when you click a PDF in Safari the best option is to delete Acrobat smiling smiley The next best option, as mentioned, is to uncheck the preference in Acrobat Reader to disable the behavior.

Regarding inline viewing within Safari, delete the Acrobat plugin. And to enable Safari's built-in PDF viewing use the following from Terminal:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

(change the NO to YES to disable inline viewing, e.g. if you wanted to have Preview open PDF files.)
Options:  Reply • Quote
Re: setting preview not adobe reader in safari
Posted by: Article Accelerator
Date: November 21, 2011 12:50PM
Quote
MEG
And to enable Safari's built-in PDF viewing use the following from Terminal:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

(change the NO to YES to disable inline viewing, e.g. if you wanted to have Preview open PDF files.)

That should not be necessary unless installing Adobe Reader modifies that system preference during installation. By default, Safari will display PDFs inline natively.
Options:  Reply • Quote
Re: setting preview not adobe reader in safari
Posted by: silvarios
Date: November 21, 2011 01:13PM
Quote
Article Accelerator
Quote
MEG
And to enable Safari's built-in PDF viewing use the following from Terminal:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

(change the NO to YES to disable inline viewing, e.g. if you wanted to have Preview open PDF files.)

That should not be necessary unless installing Adobe Reader modifies that system preference during installation. By default, Safari will display PDFs inline natively.

The work around posted also allows for Safari to push the PDF straight to Preview.app, bypassing the inline view. I would guess the additional tip was posted because of the ambiguous wording of the original subject. I too was unsure if the OP wanted native inline or Preview.app.



Edited 1 time(s). Last edit at 11/21/2011 01:14PM by silvarios.
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 100
Record Number of Users: 186 on February 20, 2020
Record Number of Guests: 5122 on October 03, 2020