The Forum is sponsored by 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
Shot firewire ports?
Posted by: Ted King
Date: May 05, 2007 11:00AM
I have a 1.25Ghz single processor MDD with 10.3.9 (1.75gigs of ram). In the only pci slot I have filled I have a Canopus ADVC50 analog to digital conversion card. To use the Canopus card I have to run a firewire cable from the card to a firewire port on the computer. I have used this for a few years without trouble. It has been several months since I last tried to use the Canopus card and a few months since I plugged my external backup firewire drive into a firewire port (I have a second internal drive I use to do my more routine backups). The only other firewire device I have is a second external drive that I use to backup my wife's computer and it had been a very long time since that was plugged into my computer.

Edit: The other firewire port could not be used for anything else when I had the Canopus card connected to one of them, but if I unplugged the Canopus card from the computer's firewire port I could use the other for my external firewire drive.

This morning I tried to use the Canopus card in iMovie (which is what I always use) and iMovie said there was no "camera" connected (that is usually what it thinks the Canopus card is). I tried replugging in the firewire cable. Restarting the computer. Replugging the cables again. Changed the firewire cable between both computer firewire ports multiple times. Switched the Canopus card to another PCI slot. I even tried pulling out the logic board battery for about 20 minutes (long shot, I know). Nothing worked. So I tried using my firewire external drive. No go. Tried the other external firewire drive. No go.

Okay, so I'm inclined to think there is a good chance the firewire ports on the logic board have gotten fried somehow (I can't think of what I could have done to cause that). What do you all think? If the firewire ports are toast, is my best bet to get a firewire PCI card? I've been tempted to get a PCI USB2 card anyway since my computer has stopped automatically going to sleep - I have to put it to sleep - and I know that there is a good chance a PCI USB2 card would have prevented sleep on my MDD computer anyway. So I'm thinking I might as well get a PCI card with USB2 and Firewire ports. Sound like a good idea? If so, any recommendations?

Edited 1 time(s). Last edit at 05/05/2007 11:02AM by Ted King.
Options:  Reply • Quote
Re: Shot firewire ports?
Posted by: lafinfil
Date: May 05, 2007 11:30AM
I had a similar problem wit a G4 running 10.3.9 a few years ago

All of a sudden for no reason the FW ports quit working and I tried everything I could think of.
TechTool could not see any devices either and I was convinced it was fried.

Someone here (or rather there) suggested doing an archive install of the OS

Having nothing to lose I did just that and the FW ports came back to life.

I have no idea why but that fix worked. May not be first choice but if all else fails it's worth a try.

Options:  Reply • Quote
Re: Shot firewire ports?
Posted by: Fritz
Date: May 05, 2007 11:41AM
you could try blowing the pRam.
Cmd-opt-P-R after the start up bong and hold for 3 cycles.

or, unplug, remove pRam batt for a minute or so.
put itt back together.
reboot run DU.

then the archive if that don't do it


What if the hokey pokey really is what it’s all about?

Options:  Reply • Quote
Re: Shot firewire ports?
Posted by: john-o
Date: May 05, 2007 12:16PM
The trick for unresponsive FW is definitely to shut down, disconnect everything, including power cord, and let sit five minutes. I don't believe you need to pull the PRAM battery either. Reconnect everything, power up, and you should be good to go.

Worked for me recently, and this was on a new Mac Pro.

Good luck,
Options:  Reply • Quote
Re: Shot firewire ports?
Posted by: Ted King
Date: May 05, 2007 01:44PM
Thanks for the advice everyone. john-o, I had disconnected the pram battery before I posted, but I forgot to unplug the computer! So I did as you said and disconnected everything, including the power cord - and the pram battery just for good measure - and then took a shower. Hooked everything back up after the shower and the firewire external drive showed up! Yay! I decided it would be a good time to make a back-up to the external drive. And then I fired up iMovie and the Canopus card showed up. Yay again!

I hope maybe this may even fix the computer not-automatically-going-to-sleep problem I was having. We'll see about that.

Thanks again!
Options:  Reply • Quote
Re: Shot firewire ports?
Posted by: fauch
Date: May 07, 2007 12:31PM
Resetting the PMU can sometimes help too.
I have had this problem on my Mini several times and it has always brought FW back from the dead....
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 785
Record Number of Users: 186 on February 20, 2020
Record Number of Guests: 5122 on October 03, 2020