advertisement
Forums

The Forum is sponsored by 
 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
Quicksilver 933 losing power
Posted by: freescotland
Date: October 02, 2007 09:25PM
My wife's Quicksilver 933 began to start without a chime and then began cutting off in the middle of pretty much anything.

I reset the PMU, and zapped pram and got the chime back and wonder what else could be going on here.

motherboard battery probably needs replacing, would that could power loss?

thanks in advance.
Options:  Reply • Quote
Re: Quicksilver 933 losing power
Posted by: fmgtech
Date: October 02, 2007 09:51PM
I had a similar problem and found out that the processor was bad. Logic board and power supply were fine.
Options:  Reply • Quote
Re: Quicksilver 933 losing power
Posted by: MacMagus
Date: October 02, 2007 10:50PM
> got the chime back and wonder what else could be going on here...

PSU's and front power boards were iffy on some runs of G4 towers. 'Could also be overheating or an electrical arc from dust in the case or a power-surge or a brownout or a USB or FW device gone awry... without more to go on, it's anybody's guess.

But if the symptom is gone, I wouldn't worry.
Options:  Reply • Quote
Re: Quicksilver 933 losing power
Posted by: freescotland
Date: October 03, 2007 02:43PM
it's a stock G4 933

I am booting off external firewire as main drive and using a usb hub with keyboard, printer, card reader plugged in.

Think it could be a firewire issue?

It's doing it again.

Does radio shack carry those motherboard batteries?
Options:  Reply • Quote
Re: Quicksilver 933 losing power
Posted by: MacMagus
Date: October 03, 2007 04:21PM
> I am booting off external firewire as main drive and using a usb hub with keyboard, printer, card reader plugged in.

The first step in troubleshooting these things is disconnecting ALL USB and FireWire peripherals other than the original Apple mouse and keyboard.

Can you run off of an internal drive for awhile?


> Think it could be a firewire issue?

'Not enough info to tell.


> Does radio shack carry those motherboard batteries?

Yes, but they charge 3x what the batteries are worth. Microcenter has them for the right price, as does OWC (although OWC seems to be back ordered at the moment.)

The batteries are 3.6v 1/2 AA Lithium. Radio Shack has purple ones, made in Israel and they call them lighter batteries.
Options:  Reply • Quote
Re: Quicksilver 933 losing power
Posted by: freescotland
Date: October 03, 2007 10:10PM
I put the drive inside and replaced the battery, it was 3x the cost, but you pay for impatience.

All seems fine now. I suspect it might have been the firewire, since I forgot my wife had added a firewire hub.

MacMagus, thanks for the replies.
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 152
Record Number of Users: 186 on February 20, 2020
Record Number of Guests: 5122 on October 03, 2020