The Forum is sponsored by 

AAPL stock: Click Here

You are currently viewing the Tips and Deals forum
Disappearing keychain?
Posted by: TL
Date: February 10, 2006 11:10PM
I did maintenance stuff on my Pismo using Onyx tonight after a kernel panic. Normally that clears things right up, and after a restart I can get back to work. This time, though, something odd happened.

My Keychain is gone. Yes, gone. The Keychain app somehow was reset, so there's nothing there. All my passwords and secure notes are gone. No, I don't have a backup. I did have one, but it was on an external drive that died recently, and I hadn't gotten around to archiving everything again. Yes, I know that's a very bad thing. Yes, I'm doing a full backup tomorrow.

This is under 10.3.9, with the most recent version of Onyx. The Onyx maintenance stuff is all stuff I've done before, so it's not like I changed some obscure setting. I tried a quick Disk Utility repair, and while permissions were repaired my Keychain is still gone.

So, any ideas what happened, and how I can recover all those passwords?
Options:  Reply • Quote
Re: Disappearing keychain?
Posted by: MacMagus
Date: February 10, 2006 11:25PM
I seriously doubt that it was anything that Onyx did. I expect that something was accessing your keychain file when you crashed and that ate it.

Look in your ~/Library/Keychains folder. There's a file there that should have your user name on it.

If it is a small file (under perhaps 32k) then it's pretty new. If it's considerably larger than that then it's your old file.

If it's a new file then your old file was lost/deleted somehow and might be recovered using an app like Data Rescue.

If it's the old file then it's probably corrupt and you may be screwed. Make a backup of the file just in case, then try the Keychain Access app and look for the Keychain First Aid option.

Edited 1 time(s). Last edit at 02/10/2006 11:26PM by MacMagus.
Options:  Reply • Quote
Re: Disappearing keychain?
Posted by: TL
Date: February 10, 2006 11:33PM
Nope, there's no file with my username in that directory. There are 3 existing files, all of which open properly and none of which have any of my passwords contained therein. I ran Keychain First AId for kicks, and it looks like no changes were made.
Options:  Reply • Quote
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 279
Record Number of Users: 186 on February 20, 2020
Record Number of Guests: 5122 on October 03, 2020